التحكم في الميكروتك من اي
مكان في العالم


اولا يجب عليك عمل الروتر
بريدج كما شرحها الاخ الفاضل


Masy
مع الروتر بريدج كلينت وداعا لمشاكل فصل الماسنجر
نهائيا



بسم الله الرحمن
الرحيم




نظرا
لوجود موضوعات كتيرة جدا تتحدث عن فصل الماسنجرات وطلب عمل الروتر بريدج اهديكم هذا
الموضوع المتواضع ولا أسالكم سوى الدعاء لى ولوالدى




بداية موضوع فصل الايميلات او المسنجرات عموما راجع لسبيب
فقط

الاول وهوا أختلاف قيمة Mtu بين الروتر والسيرفر وطبعا
انواع الروترات كتيرة جدا ولكل روتر قيمه معينه عشان يعمل بصورة جيدة مع اى نوع
سيرفر وعلاج الموضوع دا انك تستخدم الاتصال بتاعك بريدج كلينت وترتاح من وجع الدماغ
دا خالص




السبب التانى هوا فشل مدير الشبكة فى توزيع السرعات على
مشتركيه واسف ف الاسلوب دا لان فى ناس مثلا الخط بتاعها سرعته 2 ميجا وبيدى ناس
سرعه 1 ميجا وناس 2 وناس 256 فطبعا لو حسبت الاكتف بتاعك وكمان قميه السحب من الخط
هتلاقى انك عاوز بدل الخط خمس او عشرة كمان فانا اسف مش هشرح الاسلوب دا لان كل
واحد ادرى بمشتركيه وكمان لكل واحد تفكيرة




نرجع لموضوعا ومعلش انا طولت فى الكلام




شرح عمل
الروتر بريدج

هنشرح فى موضوعا ازاى تعمل الروتر بريدج وهيكون
الشرح على التبى لينك نظرا لأنتشاره وانت من الصور ممكن تفهم وتعملها مع نوع روتر
تانى





اولا دى
الاعدادت اللى هتعملها فى الروتر بتاعك





















خلصنا الروتر باقى بقى الاعدادات بتاعه السيرفر

تابع معانا




















فى نهاية الموضوع
اتمنى اكون قدرت اقدم ولو حاجه صغيرة للمنتدى العريق دا ولا اسالكم سوا دعوه فى ظهر
الغيب
[ندعوك للتسجيل في المنتدى أو التعريف بنفسك لمعاينة هذا الرابط]
احذف الايبى بتاع
الروتر







ثانيا يجب عليك التسجيل في احدي المواقع مثل DynDns او غيره من المواقع الاخري



الان نضيف الـ S c r i p t التالي ونكتب فيه بيانات موقع الـ DynDns
ثم نعمل مؤقت لتنفيذ الـ S c r i p t كل دقيقة للتأكد من تحديث الـ IP الاسمي بـ IP مزود خدمة الانترنت
كود:
# Set needed variables
:local username "YourUsername"
:local password "YourPassword"
:local hostname "nohostset"
:global systemname [/system identity get name]
:if ($systemname = "Site1" ) do= {
:set hostname "yourdomain1.dyndns.org"
}
:if ($systemname = "Site2" ) do= {
:set hostname "yourdomain2.dyndns.org"
}
:if ($systemname = "Site3" ) do= {
:set hostname "yourdomain3.dyndns.org"
}
:global dyndnsForce
:global previousIP
# print some debug info
:log info ("UpdateDynDNS: username = $username")
:log info ("UpdateDynDNS: password = $password")
:log info ("UpdateDynDNS: hostname = $hostname")
:log info ("UpdateDynDNS: previousIP = $previousIP")
# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:local result [/file get dyndns.checkip.html contents]
# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "" -1]
:local currentIP [:pick $result $startLoc $endLoc]
:log info "UpdateDynDNS: currentIP = $currentIP"
# Remove the # on next line to force an update every single time - useful for debugging, but you could end up getting blacklisted by DynDNS!
#:set dyndnsForce true
# Determine if dyndns update is needed
# more dyndns updater request details available at [ندعوك للتسجيل في المنتدى أو التعريف بنفسك لمعاينة هذا الرابط]
:if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
:set dyndnsForce false
:set previousIP $currentIP
/tool fetch user=$username password=$password mode=http address="members.dyndns.org" src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/dyndns.txt"
:local result [/file get dyndns.txt contents]
:log info ("UpdateDynDNS: Dyndns update needed")
:log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
:put ("Dyndns Update Result: ".$result)
} else={
:log info ("UpdateDynDNS: No dyndns update needed")
}








الان نستطيع الدخول على
الميكروتك من اي مكان في العالم